日記

DH57JGから地雷臭が

MacでCUDAを使ってきたけど、GPUが古めのGeforce 9400Mだから新しいGPUドライバが配布されていない。(Appleがんばれ)
CUDAドライバは最新のものを入れてるけどGPUドライバが古いからCUDAで微妙な不具合が出てたんだと思う。

色々調べたら、NVIDIAからQuadro 4000 for Macのドライバをダウンロードして、ちょっと中身を弄ってからインストールすると、Geforce 9400MでもGPUドライバを更新できるよという情報があったので、やってみたら見事にMacが起動しなくなって焦ったw
セーフモードでも起動しないとうね。
リカバリモードで起動してTime Machineから復元して事無きを得たけど。

なのでUbuntuでCUDAをやるつもり。

とりあえず、家に余ってるパーツで1台PCを組んでみた。
構成は、CPU: Xeon L3406、MB: DH57JG、メモリ: 4GB、GPU: Geforce GTX 460という感じ。

で、動かしてみたら動いたけど、古いSeasonic電源のファンが壊れて回ってない事に気づいた。
これはやばいということで、新しい電源を買った。
買ったのはKT-520RS2。いわゆるブルマ2。

さっそく電源を取り替えたら、起動しない。
電源入れても画面は真っ暗のままで、すぐにケースファンが全開で回り始める。
ビープ音もならない。(そういえばDH57JGにはビープスピーカーが付いてるけどその音を聞いたことがない。)

こりゃ電源が貧弱すぎてGTX 460の起動負荷に耐えられないのかと思い、一応520Wもあってそれは無いだろうと思ったけど、GPUをGeForce 210に替えてみたらやはり起動しない。

やはり電源がおかしいのかと思い、電源を元に戻してみても起動しない。
昨日まで起動してたのに!

新しい電源の不具合でパーツが壊れたのかと半泣きになりつつ、CMOSクリアしてみたら起動した。
よかった。
でも、新しい電源にするとやはり起動しない。
で、一回起動しなくなるとしばらく起動しない。
CMOSクリアすると起動する場合もあるけど、起動しない場合もある。

でも、一端起動するとあとは電源を落としたりしばらくコンセントを抜いたりしても安定して起動する。

混乱。

起動したときにBIOSのバージョンをみたら0625だったので最新の0663にしてみた。
でも特に状況は改善されず。

で、メモリを挿しなおしたり各種コネクタを差し替えたりしてたら新しい電源とGTX 460の組み合わせで起動した。
その後は安定して起動も動作もするようになったみたいだけどなんか釈然としない。

後で調べてみたら、DH57JGとGTX 460等の組み合わせで起動しないという報告がいくつかあった。
症状もうちと似てたので、今回は多分電源じゃなくてマザボが原因だったんだと思う。

原因としてはPCIEスロットのデバイスが変わった場合のBIOSの処理に問題があるんじゃなかろうか。
だからその1回を乗り切ればあとは安定するとか。

しかし何気にDH57JGのCPU対応表をみたら6個ぐらいしかないし。
元々Xeon非対応ではあるけど、以前はもっと対応してたような?

これからわざわざ買う人はあまりいないと思うけど、DH57JGは地雷臭がするのでお気をつけください。

コメントを残す

メールアドレスが公開されることはありません。



※画像をクリックして別の画像を表示

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください